Friday, 02 April 2021
  3 Replies
  109 Visits
0
Votes
Undo
  Subscribe

I imported the Talk topics in Chinese, however whenever I want to actually schedule a speaker, I cannot choose from the topics. I cant find the reason for it. 

Also when I want to import the watchtower epub file I always get an error message.

Any suggestions? Any setting I need to adjust, maybe? 

2 weeks ago
·
#8095
Accepted Answer
0
Votes
Undo

I am still not sure whether this is a bug, or was intentional. Nothing can be seen in weekend meetings when the info language does not match the UI language.

So for talk themes, this means they need to be defined as being in the same language as your user interface. 

So if you use English as your UI language, you will see the themes only when TB thinks they are English. To fix this there are essentially two options:

Import the talks again and define the talks as in a new language.

Probably better: the database outside of the programme itself. Identify the language ID of your user face language in the 'languages' table. Then in the 'publictalks' table replace each occurrence of lang_id with that ID. If you know a bit of sql, you could do it through a formula, but that is beyond me. If you do it manyually it is quite boring, but it will take 5 minutes or so, which may even be less than a reimport.

As for the Wachtower study, you can enter the info manually. See this post in an otherwise unrelated issue: https://www.theocbase.net/support-forum/post/8083-bug-import-w_i_202106.html#reply-8086


https://www.theocbase.net/support-forum/post/1097-donations.html

For accessing the database my personal preference is http://sqlitebrowser.org/

For editing templates I like to use http://brackets.io/ 

 


2 weeks ago
·
#8095
Accepted Answer
0
Votes
Undo

I am still not sure whether this is a bug, or was intentional. Nothing can be seen in weekend meetings when the info language does not match the UI language.

So for talk themes, this means they need to be defined as being in the same language as your user interface. 

So if you use English as your UI language, you will see the themes only when TB thinks they are English. To fix this there are essentially two options:

Import the talks again and define the talks as in a new language.

Probably better: the database outside of the programme itself. Identify the language ID of your user face language in the 'languages' table. Then in the 'publictalks' table replace each occurrence of lang_id with that ID. If you know a bit of sql, you could do it through a formula, but that is beyond me. If you do it manyually it is quite boring, but it will take 5 minutes or so, which may even be less than a reimport.

As for the Wachtower study, you can enter the info manually. See this post in an otherwise unrelated issue: https://www.theocbase.net/support-forum/post/8083-bug-import-w_i_202106.html#reply-8086


https://www.theocbase.net/support-forum/post/1097-donations.html

For accessing the database my personal preference is http://sqlitebrowser.org/

For editing templates I like to use http://brackets.io/ 

 


2 weeks ago
·
#8096
0
Votes
Undo

Hi Marc, thanks a lot for your detailed answer. 

Just a dumb question: how do I change the Language ID?  I still need the talk topics to be displayed in Chinese... 

Thanks so much! 

2 weeks ago
·
#8097
0
Votes
Undo

Oh, I found the answer. Thanks a lot. That was very helpful 

Jan selected the reply #8095 as the answer for this post — 2 weeks ago
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!