Monday, 31 January 2022
  24 Replies
  1.9K Visits
0
Votes
Undo
  Subscribe

Hi,

I've downloaded new install file onto my laptop.

In Terminal I've gone to opt/Theocbase and then typed sudo ./uninstall which worked fine.

In Terminal I've then gone back to my Download folder, typed chmod 755 TheocBase-2022.01.0-linux-x64-installer.run then sudo ./TheocBase-2022.01.0-linux-x64-installer.run 

This ran rhe installer fine, TheocBase shortcut appears in my Application menu, but when I click it, icon briefly appears on my dock, no splash screen and never launches, after a few seconds the icon then disappears from dock

I am running Elementary OS which is Ubuntu based and have never had any issues previously, I have tried removing, re-downloading and then re-installed, still get same issue.

Any ideas as to what I am doing wrong and/or what I could try please?

Thanks

Gideon

6 months ago
·
#9221
0
Votes
Undo

Hi Marlon,

Still willing to help, but heard nothing

As Andres says, providing TheocBase as a FlatPak would greatly simplify things as no commandline to install, dependancies can be pre-bundled etc. Looks super easy to convert Qt export to FlatPak:

https://docs.flatpak.org/en/latest/qt.html

Regards

Gideon

6 months ago
·
#9219
0
Votes
Undo

I have exactly the same problem on Ubuntu 20.04. I would recommend again to make a flatpak or snap available to install the app as it would prevent this kind of problems to surface in the first place and it would be much more easy to maintain and distribute for everyone. 

7 months ago
·
#9186
0
Votes
Undo

Hi brothers,

My problem is related to the post only by the title. But it's just like Reiner's (who also commented).

 

I'm on Manjaro Linux (x64). I've uninstalled & installed new version with sudo and can launch the app and edit the programme. But when I go to the Print tab, the app hangs.

I noticed that an error gets logged in JournalCtl after I launch the app - as well as when I navigate to the Print tab. I think it could be related to the issue?

 I've attached the error FYI.

7 months ago
·
#9184
0
Votes
Undo

Hi Marlon,

I'm running ElementaryOS based on 20.04 LTS, so if there is anything I can do to help please let me know

Regards

Gideon

7 months ago
·
#9180
0
Votes
Undo

If you are in the position and have the resources for one of the options, please join the team - your support would be appreciated very much!
For this task, no coding skills are required - nevertheless if you can code, you can support in other ways too of course ;-)

Greets,
Marlon

How does one join the team?

I have the time to help

Dave C

7 months ago
·
#9170
1
Votes
Undo

Hi all,

long story short: after some research it turns out, that the root of the problem is related to the following:
To create Linux packages, linuxdeployqt is used, but its documentation recommends to "build on the oldest still-supported build system" to "produce binaries that are compatible with many target systems".

Actually, this is not the case at the moment, and there was an update on the build system to a more recent openSUSE Leap distribution. Since the oldest LTS should be used, this would either require 1) the person building the packages, to stick to such a distribution for the length of its lifetime or 2) to set up and maintain another system for the sole purpose of creating the Linux packages.

If you are in the position and have the resources for one of the options, please join the team - your support would be appreciated very much!
For this task, no coding skills are required - nevertheless if you can code, you can support in other ways too of course ;-)

Greets,
Marlon

7 months ago
·
#9155
1
Votes
Undo

Hi all,

Update is that I spent over an hour yesterday looking for ways to upgrade libnss3. Other than changing distro which isn't an option I can't find a way. I tried building latest version of libnss myself but then just ran into issues with a load of other dependancies that were missing.

Going back full circle, is there a brother involved with the TheocBase development that can explain why the libnss3 requirement has changed, ie "we've moved to a new version of Qt" and also if there are any options for downgrading this requirement?

Thanks

Gideon

7 months ago
·
#9145
0
Votes
Undo

I'm running thocBase under Fedora since v32. Now updated to 35. TB is starting as always, but printing isn't working. I'm analyzing the issue

BR
Reiner

7 months ago
·
#9142
0
Votes
Undo

Ja, ich habe alles mögliches ausprobiert, TB funktioniert nur unter Ubuntu 21.10. Auf meinem Notebook sind paralell Debian 11, MX Linux und Ubuntu 21.10 installiert.

7 months ago
·
#9138
0
Votes
Undo

Hello all,
there is a way to work around the problem with the "libnss3". The testing version of Debian seems to bring the latest version of libnss3.
I tested this with "Kaisen-Linux" and the version TB 2022.01.0 works as expected. It is a French distribution based on Debian and can also be booted from a USB stick. A nice piece of software ;-)

(Hallo zusammen,
es gibt einen Weg, das Problem mit der "libnss3" zu umgehen. Die Testing-Version von Debian bringt anscheindend die neueste Version der libnss3 mit.

Getestet habe ich das mit "Kaisen-Linux" und die Version TB 2022.01.0 funktioniert wie erwartet. Es handelt sich um eine französische Distribution, die auf Debian gründet und die auch von einem USB-Stick gestartet werden kann.)

Greetings to all...

8 months ago
·
#9129
0
Votes
Undo

Howdy Gideon-

So I've spent the morning seeing if I could come up With a fix for you and the others who seem to be locked into Using O'Ss based on Ubuntu 20.04 LTS. The Elementary OS is a nifty distro designed for new linux users so it took me a little while to learn my way around the GUI and the system itself. To see if the problem would follow other programs I use, I also installed the WT Library downloaded from JW.Org (ISO file) and got it working and also Zoom. I had to jump threw a few extra hoops to install them but they both work fine.

At this point I am stumped as to a fix for this, other then Installing some other Distro that it will work with, maybe even a dual boot or wait and see if the TheocBase program is modified to run with the older NSS. It migh be possible for them to add into the install program the ability to decern the systems versions of software running and adapte and install what will work. 

For those of us that do have the newer versions of NSS 3.65 in the Distro we run the older 3.49 should work with no problem, aleast that is what the maintianers say.

 

Dave C.

8 months ago
·
#9128
0
Votes
Undo

I have setup a dual boot running the lastest Elementry OS 6.1. I downloaded TheocBase and installed it and succeced in duplicating yours and the others problem.

I run " sudo apt update " and then ran " sudo apt upgrade " which installed another 68+ files/Packages etc. Rebooted but still when starting Theocbase in terminal it will not run the same "Nss_3.65 not found" error comes up. 

I ran " sudo apt-get install Libnss3* " this should have installed the latest updates for the NSS Library but it seems that it cannot install anything newer then 3.49.

Will see if it is possble to load TheocBase ignoring the error 

8 months ago
·
#9127
0
Votes
Undo

It doesn't make sense to me that your not able to update the "NSS" files to the latest to keepup on sercurity. I'm Downloading a copy of the latest Elementry O/S and will setup my laptop to run it along side Manjaro and see if I can help figure out a fix for you

 

Dave C

8 months ago
·
#9124
0
Votes
Undo

@Felipe - Glad you got it working. Unfortunately for me and other using distros based on Ubuntu LTS, upgrading isn't an option...

Any developers care to chip in as to reason for NSS requirement changing? Thanks

8 months ago
·
#9122
0
Votes
Undo

Hello brothers, i did an ubuntu update to version 21:10 and theocbase works!

8 months ago
·
#9121
0
Votes
Undo

Sorry I'm not able to give a more direct or decisive answer but sometimes just having another set of eyes looking for an answer helps. I did come across a site listed below that covers the need to update the packages in Elementry using " APT ". From the articule it seems to be a fairly common thing to do in order to keep up with updated programs and security issues in Elementry and other distro's based on the Ubuntu LTS distro.

https://linuxhint.com/update_all_packages_elementary_os/

8 months ago
·
#9118
0
Votes
Undo

If I try running from Terminal I get:

./AppRun: /lib/x86_64-linux-gnu/libnss3.so: version `NSS_3.65' not found (required by /opt/TheocBase/bin/../lib/libsmime3.so)

If I try installing libnss3 I get the following message:

libnss3 is already the newest version (2:3.49.1-1ubuntu1.6)

Googling it brings me to this page:

https://packages.ubuntu.com/search?keywords=libnss3

To me, it seems to suggest that on 20.04 LTS (which Elementary and various other dstros are based on) the maximum version for libnss is 3.49, in order to get 3.65 or better you need to be on Ubuntu 21.10

To the brothers developing, in previous version of TheocBase (2021.10) this wasn't an issue, so obviously earlier version of NSS was being checked for. Is there a reason for the change? Can this be changed back? Thanks

 

 

 

8 months ago
·
#9117
0
Votes
Undo

you might try running TheocBase from the Termial/konsole and see if any erriors show up 

8 months ago
·
#9116
0
Votes
Undo

have you tried to update "NSS"I came across one fix "yum update NSS"

 

8 months ago
·
#9114
0
Votes
Undo

Hello brothers, Does this error message make sense?

/opt/TheocBase/AppRun: /lib/x86_64-linux-gnu/libnss3.so: version `NSS_3.65' not found (required by /opt/TheocBase/bin/../lib/libsmime3.so)

  • Page :
  • 1
  • 2
There are no replies made for this post yet.
Be one of the first to reply to this post!