1. Dimas
  2. General Issues
  3. Thursday, 29 June 2017
  4.  Subscribe via email

Hello Everyone,

After upgrading from ver. 2016.07.1 to ver. 2017.02.1 everything worked great. Then I upgraded to 2017.06.0 and now I'm getting a program start error message. Additionally, I'm unable to synchronize the database. All my PCs display a network connection error. My mobile devices still syncronize without problems. See the images below. 

OS: Windows 7 pro w/SP1 (x86)
Microsoft Visual C++ 2015 Redistributable 14.0.24215

StartErr

NetwkErr

 

Apologies for the password protection issue. Was not intended and happend by accident.

:)

  DeBary, FL 32713, USA
Visit 
Comment
There are no comments made yet.
Dimas
Members
Accepted Answer Pending Moderation
0
Votes
Undo

FYI,

I've been doing a bit of digging and I found that this dll file belongs to MS Visual C++ Redistr. During a recent update it might have changed. I'm wondering if I can just copy the dll from a working environment and paste it into the C:\Windows\System32 folder.

If anyone thinks this is something that might or could work, or has tried something similar, let me know.

Thank you all

Comment
There are no comments made yet.
  1. more than a month ago
  2. General Issues
  3. # 1
Marc
Members
Accepted Answer Pending Moderation
0
Votes
Undo

I sent some info in the PM before I saw this.
Normally upgrading the MS Visual C++ Redist does not remove earlier versions. You can check this in Configuration Screen, Installed Programmes.

I enclose how this bit looks in my case: many of those packages alongside each other. 

So maybe TheocBase does not work with the latest (honestly I do not know) but if the previous version is still there, this should not be a problem. So it might be a problem if you removed earlier versions after the update.

Attachments (1)

https://www.theocbase.net/support-forum/1097-donations.html

For accessing the database my personal preference is http://sqlitebrowser.org/

For editing templates I like to use http://brackets.io/ 

 

Comment
  1. Dimas
  2. 3 years ago
  3. #489
Thanks Marc. See the next comment below.
There are no comments made yet.
  1. more than a month ago
  2. General Issues
  3. # 2
Dimas
Members
Accepted Answer Pending Moderation
0
Votes
Undo

Thank you Marc. I do have several versions of the Visual C++ environment installed. I hadn't seen this video you sent me but it seems that it's a common problem when upgrading to newer versions of the redistributable. The workaround for my problem was precisely that, to transplant a fresh copy of the mscrv120.dll file to my troubled pc. I did it from a different working pc but the principle is the same. As soon as I copied the fresh copy of the mscrv120.dll into the C:\Windows\System32 (on a 32bit system), TheocBase started working again. The network error dissapeard as well as it seems that the problem for both symptoms is one and the same.

It seems that the newer version of the Visual C++ redist. replaces the older files as you can see in the pic below. Importing a clean copy of the file fixed this problem for me on two different PCs.

Thank you again for all your insight :)

msvcr120 dll

Comment
  1. Marc
  2. 3 years ago
  3. #490
Glad you are OK now, and that the two things are now solved at once.
There are no comments made yet.
  1. more than a month ago
  2. General Issues
  3. # 3
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!